Kali Linux出现GPG error: The following signatures were invalid: KEYEXPIRED的解决方案

by LauCyun Feb 5,2018 14:38:22 15,539 views

昨天把我的Kali Linux给搞崩了,所以只能新装一个了。

安装完后,运行apt-get update命令时,出现如下错误:

网上有说:

rm -rf /var/lib/apt/lists
apt-get update 

但是,还是不行啊!

Google一番后,看到https://forums.kali.org/showthread.php?24687-Problem-with-apt-get-update&highlight=1425567400#2的方法,于是尝试:

apt-key adv --keyserver hkp://keys.gnupg.net --recv-keys 7D8D0BF6

如上图,竟然可以了!仰天一笑,哈哈哈~~~

如果你是Ubuntu的话,遇到类似的问题,请参考apt - "GPG error:The following signatures were invalid: KEYEXPIRED" - Ask Ubuntu

Tags